NEWS
LinuxCNC 2.5.4 Release
There are no translations available.

LinuxCNC 2.5.4 Update Released (changelog).
 
LinuxCNC 2.5.3 Release
There are no translations available.

LinuxCNC 2.5.3 Update Released (changelog).
 
LinuxCNC 2.5.2 Release
There are no translations available.

LinuxCNC 2.5.2 Update Released (changelog).
 
Home Forum Hardware & Machines PC Computers parport does not work in diection "in"

Welcome, Guest
Username: Password: Remember me

TOPIC: parport does not work in diection "in"

Re:parport does not work in diection "in" 29 Nov 2011 23:19 #15218

  • grandixximo
  • grandixximo's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 96
  • Karma: 0
No it's still like that, i have make my I/O suffice in the manner that they come, i cannot change the port as i like, but the way they are it's not bad

Do you have the same problem?

What PC are you using?

I haven't really dig deep on the issue, but i'd be happy if someone found a solution...
Last Edit: 29 Nov 2011 23:20 by grandixximo.
The administrator has disabled public write access.

Re:parport does not work in diection "in" 30 Nov 2011 10:27 #15231

  • RayJr
  • RayJr's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 37
  • Karma: 2
The problem I am having is a little different.

The machine is based on an Intel Atom D510 motherboard, with the following:
a netmos based PCI parallel port card
PMDX 132 BOB board with GeckoG202s
PMDX 122 BOB card

The problem I was having was erratic stepping. I had not gotten to checking the inputs from the 122 to the PCI parallel card.
I found that when the second PP was plugged in, the supply voltage on the 122 was loaded down to about half, with a lot of ripple. That is supplied from the 132, so the 132 was effected, which effected the Geckos.
More troubleshooting exposed that I had not picked the correct i/o address for the PCI card. I started out using the address with the 16bit, but ended up using one of the 8bit locations.

A while back I had discovered that when you configure the second & third PP for IN with the StepConf wizard, the HAL file sets them as OUT. I tried setting them to OUT in StepConf, and the HAL file showed them as IN.

So now the 132 power supply is not being loaded down. I will test the inputs to he 122/second PP tonight.

One more weird anomaly I found, when I tried to plug the second PCI PP to the 132 (before I found the addressing issue), nothing worked, except the E-stop, on pin 10. I would expect no response, not a response from one pin. I duplicated the experiment with the first PP with the same result. No stepping from the drivers, but the E-stop input functioned correctly.

I still have a bunch of issues to sort out, and learning to do.

Like what StepConf puts into the following variables in the HAL file:
setp stepgen.0.position-scale [ASIS_0] SCALE
setp stepgen.0.steplen 1
setp stepgen.0.stepspace 0
setp stepgen.0.dirhold 35000
setp stepgen.0.dirsetup 16000

I would expect those variables to be single digit of >=1.

More things to learn!

I hope this was not too long winded!

Ray
The administrator has disabled public write access.
Moderators: ArcEye
Time to create page: 1.088 seconds
Powered by Kunena Forum
© 2014 LinuxCNC.org
Joomla! is Free Software released under the GNU General Public License.