NEWS
2.6 Live+Install image

Announcing a new Live+Install DVD image for installing LinuxCNC 2.6 on Debian Wheezy. Instructions here.

 
LinuxCNC 2.6.2 Released

Bug fix see the change log.

 
LinuxCNC 2.6.1 Released

Bug fix see the change log.

 

Welcome, Guest
Username: Password: Remember me

TOPIC: GladeVCP

Re:GladeVCP 13 Sep 2011 06:58 #13169

  • piasdom
  • piasdom's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 538
  • Thank you received: 1
  • Karma: 2
as far as the estop button, i tried 'control and display toggle and plain button.
and hal python toggleaction and hal_action_estop_reset1 and neither change state.
except toggleaction does turn power off once i turn on with other button.
and i have it connect with emc toggleaction estop in glade.
just to let you know in case a bug.


Thanks
kenneth
Last Edit: 13 Sep 2011 07:08 by piasdom.
The administrator has disabled public write access.

Re:GladeVCP 13 Sep 2011 07:14 #13170

  • psha
  • psha's Avatar
  • OFFLINE
  • Moderator
  • Posts: 107
  • Karma: 22
Show your UI file please.
And postgui halfile
BTW you are using estop reset action, not toggle action - they are different
ToggleAction consists of two actions - for on-off state change and for off-on
The administrator has disabled public write access.

Re:GladeVCP 13 Sep 2011 07:26 #13171

  • piasdom
  • piasdom's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 538
  • Thank you received: 1
  • Karma: 2
This attachment is hidden for guests. Please log in or register to see it.

Thanks
kenneth
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
Last Edit: 13 Sep 2011 07:26 by piasdom.
The administrator has disabled public write access.

Re:GladeVCP 13 Sep 2011 07:27 #13172

  • piasdom
  • piasdom's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 538
  • Thank you received: 1
  • Karma: 2
piasdom wrote:
This attachment is hidden for guests. Please log in or register to see it.

This attachment is hidden for guests. Please log in or register to see it.

Thanks
kenneth
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
The administrator has disabled public write access.

Re:GladeVCP 13 Sep 2011 07:47 #13173

  • psha
  • psha's Avatar
  • OFFLINE
  • Moderator
  • Posts: 107
  • Karma: 22
Yes, you are using estop reset instead of estop toggle, that's why it's only turning off machine and not turning on
The administrator has disabled public write access.

Re:GladeVCP 13 Sep 2011 07:57 #13175

  • piasdom
  • piasdom's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 538
  • Thank you received: 1
  • Karma: 2
Thanks, i did use toggle and reset, guess it was reset that i last used.
but i think i found my blunder:) . in my axis.hal i had the
net estop-out => iocontrol.0.emc-enable-in disabled because i used it for
my prvcp button. after enabling it, estop works as should. sorry for giving
you all this trouble. Thanks so much !


Thanks
kenneth
The administrator has disabled public write access.
Moderators: mhaberler
Time to create page: 0.789 seconds
Powered by Kunena Forum
© 2014 LinuxCNC.org
Joomla! is Free Software released under the GNU General Public License.